Changes between Version 3 and Version 4 of CompilingMindSeer


Ignore:
Timestamp:
09/26/06 10:52:12 (12 years ago)
Author:
ebmoore
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • CompilingMindSeer

    v3 v4  
    88 1. Install Java3D 1.3 (1.4 may work, but is untested) 
    99 1. Get MindSeer out of SVN 
    10  1. Go into Eclipse and set the build path to point at everything in the lib directory (under project>perferences>compile>build path). 
     10 1. Go into the Project Build Path (under project>perferences>java build path) and set the '''Source'''  to exlude files '''**/Mac*.java''' (unless you are on a Mac). 
     11 1. Go into the Project Build Path (under project>perferences>java build path) and set the '''Libraries'''  to point at everything in the lib directory. 
    1112 1. Do one of the following with javaws.jar ''or'' jnlp.jar (one of these should be in the java install directory): 
    12    1. Copy ''or'' link the jar file into the lib directory and add to build path. 
     13   1. Copy ''or'' link the jar file into the lib directory and add to the Library build path. 
    1314   1. Add the jar file to the build path. 
    1415 1. Ensure Java 5 is the default. 
    15  1. Run ant with target help (open build.xml, browse the outline for help, right click and run) to make sure the help file is up to date.  Add help.jar to build path. 
     16 1. Run ant with target help (open build.xml, browse the outline for help, right click and run) to make sure the help file is up to date.  Add help.jar to the Library build path. 
    1617 1. (Optional) change the compile warnings for serialUID to no warning.  I disagree with the need to set this number because I ''want'' different versions to be incompatible.  
    1718