wiki:CompilingMindSeer
Last modified 11 years ago Last modified on 12/11/06 15:38:13

How to Compile MindSeer

While MindSeer isn't tricky to compile, there are a few things you need to do. This page includes an Ant? build and an Eclipse? build.

Eclipse

  1. Install Java 5.0 or above (AKA 1.5+)
  2. Install Eclipse 3.1+
  3. Install Java3D 1.3 (1.4 may work, but is untested)
  4. Get MindSeer out of SVN
  5. Go into the Project Build Path (under project>perferences>java build path) and set the Source to exlude files /Mac*.java (unless you are on a Mac).
  6. Go into the Project Build Path (under project>perferences>java build path) and set the Libraries to point at everything in the lib directory.
  7. Ensure Java 5+ is the default.
  8. Run ant with target help (open build.xml, browse the outline for help, right click and run) to make sure the help file is up to date. Add help.jar to the Library build path.
  9. (Optional) change the compile warnings for serialUID to no warning. I disagree with the need to set this number because I want different versions to be incompatible.

Ant

  1. Install Java 5.0 or above (AKA 1.5+)
  2. Install Java3D 1.3 (1.4 may work, but is untested)
  3. Install Ant?
  4. Get MindSeer out of SVN
  5. Run Ant?, read build.xml's header for target information.